注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

z-1970528的博客

 
 
 

日志

 
 

【转载】通达信 几种均线实用的选股 指标源码  

2014-12-30 21:46:14|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

1、四合一金叉选股公式

一个5日均线金叉10日均线,成交量5日均量金叉10日均量,MACD金叉,KDJ金叉,上面四个条件满足三个同时金叉就可以成立的选股公式:
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
MA1:=MA(VOL,5);
MA2:=MA(VOL,10);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
A1:=DEA;
F1:=DIF;
K1:="KDJ.K";
J1:="KDJ.J";
金叉1:=CROSS(M1,M2);
金叉2:=CROSS(MA1,MA2);
金叉3:=CROSS(F1,A1);
金叉4:=CROSS(J1,K1);
选1:=金叉1 AND 金叉2 AND 金叉3 AND 金叉4;
选2:=金叉1 AND 金叉2 AND 金叉3;
选3:=金叉2 AND 金叉3 AND 金叉4;
选4:=金叉1 AND 金叉2 AND 金叉4;
选5:=金叉1 AND 金叉3 AND 金叉4;
选股:选1 OR 选2 OR 选3 OR 选4 OR 选5;

 

2、均价线,均量线,KDJ三金叉

MA5:=EMA(C,5);
MA10:=EMA(C,10);
MV5:=EMA(V,5);
MV10:=EMA(V,10);
K:="KDJ.K"(9,3,3);
D:="KDJ.D"(9,3,3);
V1:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND C>REF
(C,1) AND C/O>1.01;
VV1:=MV5>REF(MV5,1) AND MV10>=REF(MV10,1) AND 
V>REF(V,1)*1.2 ;
KD1:=K>REF(K,1) AND D>=REF(D,1);
VA:=COUNT(CROSS(K,D),4)>=1 AND COUNT(CROSS
(MA5,MA10),4)>=1 AND
COUNT(CROSS(MV5,MV10),4)>=1;
XG1:IF(V1 AND VV1 AND KD1 AND VA,1,0);

 

 

3、5、10 日线,5、10日均量线,MACD。
{三金叉选股}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
M5:=MA(C,5);
M10:=MA(C,10);
V10:=MA(VOL,10);
V5:=MA(VOL,5);
三金叉:CROSS(M5,M10) AND CROSS(DIF,DEA) AND CROSS
(V5,V10);
 
   副图用,智能选股,三金叉>0 即可。
   注意,该方法选出的股还要注意是在股价的高位还是低
位。方考虑介入。 
 
   

4、三金叉选股,均价线,均量线,KDJ三金叉

 

可以加主图,可选股
KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:=
"KDJ.J"(9,3,3);
买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND 
KDJ_D<26);
买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS
("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS
("MACD.MACD",0);
买0:=买1+买2+买3;
{买:IF(买0>1,买0,0);}

DRAWICON(买0>1,L*0.98,16);

 

5、三金叉选股----见底回升的重要信号
{SJC XG 三金叉选股}
   三金叉的出现,在技术分析“价、量、时、空”四大要素中有三个发出买入信号,将极大地提高研判准确性的概率,因此三线合一的三金叉为强烈的见底买入信号。

  第一个买点为三金叉发生时。所谓的5日、10日均线、均量线以及MACD三金叉并非绝对要求同时或同一天金叉的,这仅是一种简单的描述。事实上均线、均量线及MACD三金叉只要在几个交易日之内发生,都可视同于“三金叉”,由于探底之前往往有一个放量的过程,均量线的金叉往往是第一个出现,三者当中最后一项发生金叉时就是短中线的买入信号。

  第二个买点为三金叉发生后上攻途中出现回档时。三金叉见底发生时,投资者当时有可能没有注意到这种极好的短线介入点,其实在错过三金叉见底发生的买入信号之后,投资者仍可等待股价回档时出现的第二个买机,最有效的方法是
股价在回档时可在10日或20日均线附近可逢低吸纳。只要股价仍保持原始上升趋势,这种逢低吸纳不失为较好的介入时机。 }

{SJC XG 三金叉选股}
MA5:=EMA(C,5);
MA10:=EMA(C,10);
VV1:=CROSS(MA5,MA10);
VVV1:=COUNT(VV1,5)>=1;
MV5:=EMA(V,5);
MV10:=EMA(V,10);
VV2:=CROSS(MV5,MV10);
VVV2:=COUNT(VV2,5)>=1;
DIF:="MACD.DIF"(12,26,9);
DEA:="MACD.DEA"(12,26,9);
VV3:=CROSS(DIF,DEA);
VVV3:=COUNT(VV3,5)>=1;
AA:=VVV1 AND VVV2 AND VVV3;
XG1:IF(AA,1,0);

 
6、一阳穿三线选股公式:
一根阳K线上穿 三条均线

公式源码
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
低:=REF(C,1)
高:=CROSS(C,MA5) AND CROSS(C,MA10) AND CROSS(C,MA5);
选股:低 AND 高;


7、次日涨停公式
   今天要为大家介绍一种比较实用的股票公式,这一公式我们能够很好的抓住涨停板股票,这一公式就是次日涨停公式。投资者都想要抓涨停板,但往往又是不得要领,究其原因就是没有掌握抓涨停技巧的精髓,没有一种适合的工具来协助我们。本文为大家介绍的次日涨停公式就能够满足投资者的需求,帮助大家抓住涨停,投资获利。下面就为朋友们总结次日涨停公式:
    A : MA(CLOSE,26);
    UP: A + 2*STD(CLOSE,26);
    LOWER: A - 2*STD(CLOSE,26);
    W1:=C=HHV(C,20);
    W2:=BARSLAST(W1);
    W3:=IF(W2>0,REF(C,W2),REF(C,W2));
    W4:=CROSS(C,REF(W3,1));
    DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);
    以上便是次日涨停公式的源代码,希望朋友们能够从中获得抓住涨停板的技巧,掌握这一公式的精髓一定能给大家带来不小的收获。 


四线看涨公式 
    1、每一 天的最高价和最低价,都低于四条线,通常都可买在底部。

     2、四条线处在全天的最高价和最低价之间,可以顺势买入。
    EMA5:EMA(C,5),COLOR00FF00;
    EMA10:EMA(C,10),COLORYELLOW;
    EMA20:EMA(C,20),COLORFF00FF;{20日均线通常被称为脊梁线}
    EMA30:EMA(C,30),COLORFFCCCC;{30日均线通常被称为生命线}
    W1:=C=HHV(C,20);
    W2:=BARSLAST(W1);
    W3:=IF(W2>0,REF(C,W2),REF(C,W2));
    W4:=CROSS(C,REF(W3,1));
    以上就是四线看涨公式,他对我们分析大盘形势及个股的情况有着重要的意义,我们利用四线看涨公式及股票看盘知识的帮助,分析大盘,精选个股,掌握如何选股分析股票的技巧,帮助我们在股市投资中获得优势地位。
 
 


 

条件选股公式D!LYT (老鸭头) 缺省周期:日线  
      MA5 := MA(close,5);  
      MA10 := MA(close,10);  
      MA60 := MA(close,60);  
      pday1 := barslast(cross(ma5,ma60));{5日均线上穿60日均线}  
      pday2 := barslast(cross(ma10,ma60));{10日均线上穿60日均线,至此形成鸭颈部}  
      pday3 := barslast(high=hhv(high,pday2));{形成头部,要下跌}  
      pday4 := barslast(cross(ma10,ma5));{下跌后,5日均线和10日均线死叉}  
      pday5 := barslast(cross(ma5,ma10));{回落不久,5日均线和10日均线形成金叉,形成嘴部}  
      a1:= pday1>pday2 and pday2>pday3 and pday3>pday4 and pday4>pday5 and pday5<5;  
      a2:= count(cross(ma10,ma5),pday2)=1;  
      A1 AND A2;  
老鸭头:  
      (1)采用5、10和60周期的价格平均线。当5日、10日均线放量上穿60日平均线后,形成鸭颈部。  
      (2)股价回落时形成的高点形成鸭头部。  
      (3)当股价回落不久,5日、10日均线再次金叉向上形成鸭嘴部。  
      操作:  
      (1)在5日、10日均线放量上穿60日平均线形成鸭颈部时买入。  
      (2)在鸭嘴部附近成交量芝麻点一带逢低买入。  
      (3)当股价放量冲过鸭头顶瞬间时介入。  

通达信 几种均线实用的选股 指标源码 - 指标库 - 萱箫
波浪理论21幅基本图形K线形态分析【金融经典】
波浪理论目标位测算K线形态分析2【金融经典】
天鹰开路形态金牡丹技术分析K线形态【PPT】
胡立阳股票投资制胜30秘则_完整带图形态分析的经典资料(精华整理)
“翻倍黑马”选股系统揭秘六种必涨形态
如何区分真假突破机会(内部资料请勿外传)已排版A股看盘,重点看前面一个小时
股市必胜战法十八招短线绝招18式
三线开花战法和股市倍增术的结合高位放量操作原理图解 
牛股操作模式 涨停板的长相
寻找金蜘蛛底部放量就买入
   
  评论这张
 
阅读(73)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017